Home    |    View Topics    |    Search    |    Contact Us    |   



Category:   Application (Web Server/CGI)  >   Apache HTTPD Vendors:   Apache Software Foundation
Apache mod_proxy_ajp HTTP Processing Error Lets Remote Users Deny Service
SecurityTracker Alert ID:  1026054
SecurityTracker URL:
CVE Reference:   CVE-2011-3348   (Links to External Site)
Date:  Sep 15 2011
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 2.2.21
Description:   A vulnerability was reported in Apache mod_proxy_ajp. A remote user can cause denial of service conditions.

When mod_proxy_ajp is used together with mod_proxy_balancer, a remote user can send specially crafted HTTP requests to place the backend server in an error state until the retry timeout expires.

Impact:   A remote user can cause the backend server to remain in an error state until the retry timeout expires.
Solution:   The vendor has issued a fix (2.2.21).
Vendor URL: (Links to External Site)
Cause:   Input validation error, State error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Sep 27 2011 (HP Issues Fix for HP-UX) Apache mod_proxy_ajp HTTP Processing Error Lets Remote Users Deny Service
HP has issued a fix for HP-UX 11.23 and 11.31.
Oct 20 2011 (Red Hat Issues Fix) Apache mod_proxy_ajp HTTP Processing Error Lets Remote Users Deny Service
Red Hat has issued a fix for Red Hat Enterprise Linux 6.
Nov 3 2011 (HP Issues Fix for HP OpenView Network Node Manager) Apache mod_proxy_ajp HTTP Processing Error Lets Remote Users Deny Service
HP has issued a fix for HP OpenView Network Node Manager.

 Source Message Contents

Subject:  Apache HTTP Server 2.2.21 Released

   The Apache Software Foundation and the Apache HTTP Server Project are
   pleased to announce the release of version 2.2.21 of the Apache HTTP
   Server ("Apache").  This version of Apache is principally a security
   and bug fix release:

     * SECURITY: CVE-2011-3348 (
       mod_proxy_ajp when combined with mod_proxy_balancer: Prevents
       unrecognized HTTP methods from marking ajp: balancer members
       in an error state, avoiding denial of service.

     * SECURITY: CVE-2011-3192 (
       core: Further fixes to the handling of byte-range requests to use
       less memory, to avoid denial of service. This patch includes fixes
       to the patch introduced in release 2.2.20 for protocol compliance,
       as well as the MaxRanges directive.

   Note the further advisories on the state of CVE-2011-3192 will no longer
   be broadcast, but will be kept up to date at;

   We consider this release to be the best version of Apache available, and
   encourage users of all prior versions to upgrade.

   Apache HTTP Server 2.2.21 is available for download from:

   Please see the CHANGES_2.2 file, linked from the download page, for a
   full list of changes.  A condensed list, CHANGES_2.2.21 provides the
   complete list of changes since 2.2.19.  A summary of all of the security
   vulnerabilities addressed in this and earlier releases is available:

   This release includes the Apache Portable Runtime (APR) version 1.4.5
   and APR Utility Library (APR-util) version 1.3.12, bundled with the tar
   and zip distributions.  The APR libraries libapr and libaprutil (and
   on Win32, libapriconv version 1.2.1) must all be updated to ensure
   binary compatibility and address many known security and platform bugs.

   Apache 2.2 offers numerous enhancements, improvements, and performance
   boosts over the 2.0 codebase.  For an overview of new features
   introduced since 2.0 please see:

   This release builds on and extends the Apache 2.0 API.  Modules written
   for Apache 2.0 will need to be recompiled in order to run with Apache
   2.2, and require minimal or no source code changes.

   When upgrading or installing this version of Apache, please bear in mind
   that if you intend to use Apache with one of the threaded MPMs (other
   than the Prefork MPM), you must ensure that any modules you will be
   using (and the libraries they depend on) are thread-safe.


Go to the Top of This SecurityTracker Archive Page

Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2021, LLC