SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (VPN)  >   OpenVPN Vendors:   openvpn.net
(Ubuntu Issues Fix) OpenVPN Blowfish Cipher Block Collision Weakness Lets Remote Users Decrypt Data in Certain Cases
SecurityTracker Alert ID:  1038769
SecurityTracker URL:  http://securitytracker.com/id/1038769
CVE Reference:   CVE-2016-6329   (Links to External Site)
Date:  Jun 22 2017
Impact:   Disclosure of system information, Disclosure of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  Exploit Included:  Yes  

Description:   A vulnerability was reported in OpenVPN. A remote user can decrypt transmitted data in certain cases.

A remote user that can monitor the network and can capture a long duration Blowfish CBC mode encrypted TLS session over which some amount of known plaintext is communicated can recover some plaintext in certain cases.

Over the duration of a long-lived connection, a cipher block collision may occur, allowing the remote user to recover the exclusive OR between the two plaintext blocks. If the communications protocol sends a fixed plaintext portion repeatedly and also sends some amount of known plaintext, the user can recover the secret plaintext.

[Editor's note: The report confirms a successful attack to recover secure HTTP cookies by capturing 785 GB of network traffic.]

The attack method is known as a SWEET32 attack.

64-bit block ciphers, such as 3DES and Blowfish, are affected by this type of attack.

The original advisory will be presented at the 23rd ACM Conference on Computer and Communications Security and is available at:

https://sweet32.info/SWEET32_CCS16.pdf

Karthikeyan Bhargavan and Gaetan Leurent from INRIA reported this vulnerability.

Impact:   A remote user that can monitor the network can decrypt transmitted data in certain cases.
Solution:   Ubuntu has issued a fix.

The Ubuntu advisory is available at:

https://www.ubuntu.com/usn/usn-3339-1

Vendor URL:  www.ubuntu.com/usn/usn-3339-1 (Links to External Site)
Cause:   Access control error
Underlying OS:  Linux (Ubuntu)
Underlying OS Comments:  14.04 LTS, 16.04 LTS, 16.10, 17.04

Message History:   This archive entry is a follow-up to the message listed below.
Aug 26 2016 OpenVPN Blowfish Cipher Block Collision Weakness Lets Remote Users Decrypt Data in Certain Cases



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2022, SecurityGlobal.net LLC