SecurityTracker.com
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 


Category:   Application (Generic)  >   libwmf Vendors:   wvware.sourceforge.net
(Oracle Issues Fix for Oracle Linux) libwmf Heap Overflow and Memory Corruption Flaws Let Remote Users Deny Service and Execute Arbitrary Code
SecurityTracker Alert ID:  1033910
SecurityTracker URL:  http://securitytracker.com/id/1033910
CVE Reference:   CVE-2015-0848, CVE-2015-4588, CVE-2015-4695, CVE-2015-4696   (Links to External Site)
Date:  Oct 21 2015
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 0.2.8.4
Description:   Multiple vulnerabilities were reported in libwmf. A remote user can cause arbitrary code to be executed on the target system. A remote user can cause the target service to crash.

A remote user can create a specially crafted BMP file that, when processed by the target application using libwmf, will trigger a heap overflow and execute arbitrary code on the target system [CVE-2015-0848]. The code will run with the privileges of the target application.

A remote user can create a specially crafted WMF file that, when processed by the target application using libwmf, will trigger a heap overflow in the DecodeImage() function and execute arbitrary code on the target system [CVE-2015-4588]. The code will run with the privileges of the target application.

A remote user can create a specially crafted WMF file that, when processed by the target application using libwmf, will trigger an out-of-bounds read and cause denial of service conditions [CVE-2015-4695].

A remote user can create a specially crafted WMF file that, when processed by the target application using libwmf, will trigger a use-after-free in the wmf2gd or wmf2eps commands and cause denial of service conditions [CVE-2015-4696].

Impact:   A remote user can create content that, when loaded by the target user, will execute arbitrary code on the target user's system.

A remote user can cause denial of service conditions on the target application.

Solution:   Oracle has issued a fix.

The Oracle Linux advisory is available at:

http://linux.oracle.com/errata/ELSA-2015-1917.html

Vendor URL:  linux.oracle.com/errata/ELSA-2015-1917.html (Links to External Site)
Cause:   Access control error, Boundary error
Underlying OS:  Linux (Oracle)
Underlying OS Comments:  6, 7

Message History:   This archive entry is a follow-up to the message listed below.
Jul 2 2015 libwmf Heap Overflow and Memory Corruption Flaws Let Remote Users Deny Service and Execute Arbitrary Code



 Source Message Contents

Subject:  [El-errata] ELSA-2015-1917 Important: Oracle Linux 6 libwmf security update

Oracle Linux Security Advisory ELSA-2015-1917

http://linux.oracle.com/errata/ELSA-2015-1917.html

The following updated rpms for Oracle Linux 6 have been uploaded to the 
Unbreakable Linux Network:

i386:
libwmf-0.2.8.4-25.el6_7.i686.rpm
libwmf-devel-0.2.8.4-25.el6_7.i686.rpm
libwmf-lite-0.2.8.4-25.el6_7.i686.rpm

x86_64:
libwmf-0.2.8.4-25.el6_7.i686.rpm
libwmf-0.2.8.4-25.el6_7.x86_64.rpm
libwmf-devel-0.2.8.4-25.el6_7.i686.rpm
libwmf-devel-0.2.8.4-25.el6_7.x86_64.rpm
libwmf-lite-0.2.8.4-25.el6_7.i686.rpm
libwmf-lite-0.2.8.4-25.el6_7.x86_64.rpm


SRPMS:
http://oss.oracle.com/ol6/SRPMS-updates/libwmf-0.2.8.4-25.el6_7.src.rpm



Description of changes:

[0.2.8.4-25]
- Resolves: rhbz#1227428 - CVE-2015-0848 CVE-2015-4588 CVE-2015-4695 
CVE-2015-4696

[0.2.8.4-24]
- Resolves: rhbz#1227429 CVE-2015-0848 libwmf: heap overflow when 
decoding BMP images


_______________________________________________
El-errata mailing list
El-errata@oss.oracle.com
https://oss.oracle.com/mailman/listinfo/el-errata
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

This web site uses cookies for web analytics. Learn More

Copyright 2022, SecurityGlobal.net LLC