SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Multimedia)  >   Adobe Flash Vendors:   Adobe Systems Incorporated
Adobe Flash Player Buffer Overflows and Memory Corruption Errors Let Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1027730
SecurityTracker URL:  http://securitytracker.com/id/1027730
CVE Reference:   CVE-2012-5274, CVE-2012-5275, CVE-2012-5276, CVE-2012-5277, CVE-2012-5278, CVE-2012-5279, CVE-2012-5280   (Links to External Site)
Date:  Nov 7 2012
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 11.4.402.287 and prior for Windows and OS X; 11.2.202.243 and prior for Linux
Description:   Several vulnerabilities were reported in Adobe Flash Player. A remote user can cause arbitrary code to be executed on the target user's system.

A remote user can create specially crafted Flash content that, when loaded by the target user, will execute arbitrary code on the target system. The code will run with the privileges of the target user.

Buffer overflows can trigger code execution [CVE-2012-5274, CVE-2012-5275, CVE-2012-5276, CVE-2012-5277, CVE-2012-5280].

Memory corruption flaws can trigger code execution [CVE-2012-5279].

A security bypass flaw can trigger code execution [CVE-2012-5278].

Eduardo Vela Nava, Mateusz Jurczyk, Gynvael Coldwind, and Fermin Serna of the Google Security Team reported these vulnerabilities.

Impact:   A remote user can create content that, when loaded by the target user, will execute arbitrary code on the target user's system.
Solution:   The vendor has issued a fix (11.5.502.110 for Windows and OS X, 11.2.202.251 for Linux, 11.1.111.24 for Android 2.x and 3.x, 11.1.115.27 for Android 4.x, 11.5.31.2 for Chrome, 11.3.376.12 for Internet Explorer 10).

The vendor's advisory is available at:

http://www.adobe.com/support/security/bulletins/apsb12-24.html

Vendor URL:  www.adobe.com/support/security/bulletins/apsb12-24.html (Links to External Site)
Cause:   Access control error, Boundary error
Underlying OS:   Android, Linux (Any), UNIX (OS X), UNIX (Solaris - SunOS), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Nov 7 2012 (Red Hat Issues Fix) Adobe Flash Player Buffer Overflows and Memory Corruption Errors Let Remote Users Execute Arbitrary Code   (bugzilla@redhat.com)
Red Hat has issued a fix for Red Hat Enterprise Linux 5 and 6.
May 16 2013 (RIM Issues Fix for BlackBerry PlayBook) Adobe Flash Player Buffer Overflows and Memory Corruption Errors Let Remote Users Execute Arbitrary Code
RIM has issued a fix for BlackBerry Tablet OS.



 Source Message Contents

Date:  Wed, 07 Nov 2012 01:08:51 +0000
Subject:  Adobe Flash Player


http://www.adobe.com/support/security/bulletins/apsb12-24.html

CVE-2012-5274, CVE-2012-5275, CVE-2012-5276, CVE-2012-5277, CVE-2012-5278, CVE-2012-5279, CVE-2012-5280

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC