SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   Wireshark Vendors:   Wireshark.org
Wireshark HSRP/PPP/LDP Bugs Let Remote Users Deny Service
SecurityTracker Alert ID:  1027604
SecurityTracker URL:  http://securitytracker.com/id/1027604
CVE Reference:   CVE-2012-5237, CVE-2012-5238, CVE-2012-5240   (Links to External Site)
Date:  Oct 3 2012
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 1.8.0 - 1.8.2
Description:   Several vulnerabilities were reported in Wireshark. A remote user can cause denial of service conditions.

A remote user can send specially crafted HSRP data to cause the target dissector to enter an infinite loop [CVE-2012-5237].

A remote user can send specially crafted PPP data to cause the target dissector to crash [CVE-2012-5238].

A remote user can send specially crafted LDP data to trigger a buffer overflow and cause the target dissector to crash [CVE-2012-5240]. Laurent Butti reported this vulnerability.

Impact:   A remote user can cause the target dissector to crash or enter an infinite loop.
Solution:   The vendor has issued a fix (1.8.3).

The vendor's advisories are available at:

http://www.wireshark.org/security/wnpa-sec-2012-26.html
http://www.wireshark.org/security/wnpa-sec-2012-27.html
http://www.wireshark.org/security/wnpa-sec-2012-29.html

Vendor URL:  www.wireshark.org/security/wnpa-sec-2012-26.html (Links to External Site)
Cause:   Boundary error, State error
Underlying OS:   Linux (Any), UNIX (Any), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Jan 16 2013 (Oracle Issues Fix for Solaris) Wireshark HSRP/PPP/LDP Bugs Let Remote Users Deny Service
Oracle has issued a fix for Solaris 11.1.



 Source Message Contents

Date:  Wed, 03 Oct 2012 16:21:47 +0000
Subject:  Wireshark


http://www.wireshark.org/security/wnpa-sec-2012-26.html
http://www.wireshark.org/security/wnpa-sec-2012-27.html
http://www.wireshark.org/security/wnpa-sec-2012-29.html

CVE-2012-5237
CVE-2012-5238
CVE-2012-5240
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC