SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   libpng Vendors:   libpng.sourceforge.net
libpng png_set_text_2() Memory Corruption Error May Let Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1026879
SecurityTracker URL:  http://securitytracker.com/id/1026879
CVE Reference:   CVE-2011-3048   (Links to External Site)
Date:  Mar 30 2012
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 1.5.9 and prior versions
Description:   A vulnerability was reported in libpng. A remote user can cause arbitrary code to be executed on the target user's system.

A remote user can create a specially crafted PNG file that, when loaded by the target user or application, will trigger a memory corruption error in png_set_text_2() and potentially execute arbitrary code on the target system. The code will run with the privileges of the target user or application.

Impact:   A remote user can create a file that, when loaded by the target user or application, will execute arbitrary code on the target system.
Solution:   The vendor has issued a fix (1.5.10).

The vendor's advisory is available at

http://www.libpng.org/pub/png/src/libpng-1.5.10-README.txt

Vendor URL:  www.libpng.org/pub/png/libpng.html (Links to External Site)
Cause:   Access control error
Underlying OS:   Linux (Any), UNIX (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Apr 25 2012 (Red Hat Issues Fix) libpng png_set_text_2() Memory Corruption Error May Let Remote Users Execute Arbitrary Code   (bugzilla@redhat.com)
Red Hat has issued a fix for Red Hat Enterprise Linux 5 and 6.
Mar 15 2013 (Oracle Issues Fix for Solaris) libpng png_set_text_2() Memory Corruption Error May Let Remote Users Execute Arbitrary Code
Oracle has issued a fix for Solaris 10 and 11.1.



 Source Message Contents

Date:  Fri, 30 Mar 2012 20:43:00 +0000
Subject:  libpng


http://www.libpng.org/pub/png/src/libpng-1.5.10-README.txt

Libpng 1.5.10 - March 29, 2012

> Revised png_set_text_2() to avoid potential memory corruption (fixes CVE-2011-3048).
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC