SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (E-mail Server)  >   Postfix Vendors:   Postfix.org
Postfix SASL Authentication Heap Overflow Lets Remote Users Deny Service
SecurityTracker Alert ID:  1025521
SecurityTracker URL:  http://securitytracker.com/id/1025521
CVE Reference:   CVE-2011-1720   (Links to External Site)
Date:  May 11 2011
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to versions 2.5.13, 2.6.10, 2.7.4, 2.8.3
Description:   A vulnerability was reported in Postfix. A remote user can cause denial of service conditions.

A remote user can send a specially crafted SASL authentication request to trigger a heap overflow and cause the target service to crash. Systems using the Cyrus SASL library with authentication mechanisms other than PLAN and LOGIN are affected.

Examples of affected Cyrus SASL authentication methods include CRAM-MD5, DIGEST-MD5, EXTERNAL, GSSAPI, KERBEROS_V4, NTLM, OTP, PASSDSS-3DES-1, and SRP.

Remote code execution may be possible but was not confirmed in the report.

Thomas Jarosch of Intra2net AG reported this vulnerability.

Impact:   A remote user can cause the target service to crash.
Solution:   The vendor has issued a fix (2.5.13, 2.6.10, 2.7.4, 2.8.3).

The vendor's advisory is available at:

http://www.postfix.org/CVE-2011-1720.html

Vendor URL:  www.postfix.org/CVE-2011-1720.html (Links to External Site)
Cause:   Boundary error
Underlying OS:   Linux (Any), UNIX (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
May 31 2011 (Red Hat Issues Fix) Postfix SASL Authentication Heap Overflow Lets Remote Users Deny Service   (bugzilla@redhat.com)
Red Hat has issued a fix for Red Hat Enterprise Linux 4, 5, and 6.



 Source Message Contents

Date:  Wed, 11 May 2011 17:57:24 +0000
Subject:  Postfix


http://www.postfix.org/CVE-2011-1720.html

Memory corruption in Postfix SMTP server Cyrus SASL support (CVE-2011-1720)


 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC