SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Security)  >   Kerberos Vendors:   MIT
Kerberos KDC Database Propagation Daemon Input Validation Flaw Lets Remote Users Deny Service
SecurityTracker Alert ID:  1025035
SecurityTracker URL:  http://securitytracker.com/id/1025035
CVE Reference:   CVE-2010-4022   (Links to External Site)
Date:  Feb 8 2011
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): krb5-1.7 and later
Description:   A vulnerability was reported in the Kerberos KDC Database Propagation Daemon. A remote user can cause denial of service conditions.

A remote user can send specially crafted data to the target MIT krb5 KDC database propagation daemon (kpropd) to cause the daemon to terminate its listening process. This will prevent database propagations to the KDC host on which the daemon was running.

Configurations where kpropd is running in standalone mode (the "-S" option) is affected.

Configurations where kpropd runs in incremental propagation mode ("iprop") or as an inetd server are not affected.

Keiichi Mori of Red Hat reported this vulnerability.

Impact:   A remote user can cause denial of service conditions.
Solution:   The vendor has issued a patch, available at:

http://web.mit.edu/kerberos/advisories/2011-001-patch.txt

The fix will be included in future patch releases for 1.7, 1.8, and 1.9.

The vendor's advisory is available at:

http://web.mit.edu/kerberos/advisories/MITKRB5-SA-2011-001.txt

Vendor URL:  web.mit.edu/kerberos/advisories/MITKRB5-SA-2011-001.txt (Links to External Site)
Cause:   Input validation error
Underlying OS:   Linux (Any), UNIX (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Feb 9 2011 (Red Hat Issues Fix) Kerberos KDC Database Propagation Daemon Input Validation Flaw Lets Remote Users Deny Service   (bugzilla@redhat.com)
Red Hat has issued a fix for Red Hat Enterprise Linux 6.
Mar 9 2011 (Oracle Issues Fix) Kerberos KDC Database Propagation Daemon Input Validation Flaw Lets Remote Users Deny Service
Oracle has issued a fix for Solaris 10 and Solaris 11 Express.



 Source Message Contents

Date:  Tue, 08 Feb 2011 22:34:49 +0000
Subject:  Kerberos


http://web.mit.edu/kerberos/advisories/MITKRB5-SA-2011-001.txt

CVE-2010-4022
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC