SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   HPE Linux Imaging and Printing Project (hplip) Vendors:   hplip.sourceforge.net
HP Linux Imaging and Printing Project (hplip) Buffer Overflow in hpmud_get_pml() Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1024967
SecurityTracker URL:  http://securitytracker.com/id/1024967
CVE Reference:   CVE-2010-4267   (Links to External Site)
Date:  Jan 17 2011
Impact:   Execution of arbitrary code via network, User access via network

Version(s): 3.10.9
Description:   A vulnerability was reported in HP Linux Imaging and Printing Project (hplip). A remote user can execute arbitrary code on the target system.

A remote user can send a specially crafted SNMP response when the target user is running certain hplip tools to trigger a buffer overflow and execute arbitrary code on the target user's system. The code will run with the privileges of the target user.

The vulnerability resides in hpmud_get_pml() in '/io/hpmud/pml.c'.

Sebastian Krahmer of the SuSE Security Team reported this vulnerability.

Impact:   A remote user can execute arbitrary code on the target system.
Solution:   No solution was available at the time of this entry.
Vendor URL:  hplip.sourceforge.net/ (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Jan 17 2011 (Red Hat Issues Fix) HP Linux Imaging and Printing Project (hplip) Buffer Overflow in hpmud_get_pml() Lets Remote Users Execute Arbitrary Code
Red Hat has issued a fix for Red Hat Enterprise Linux 5 and 6.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2016, SecurityGlobal.net LLC