SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   BlackBerry Enterprise Server Vendors:   Research In Motion Limited
BlackBerry Enterprise Server Buffer Overflow in Attachment Service Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1024891
SecurityTracker URL:  http://securitytracker.com/id/1024891
CVE Reference:   CVE-2010-2602   (Links to External Site)
Date:  Dec 15 2010
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 4.1.3 through 5.0.2
Description:   A vulnerability was reported in BlackBerry Enterprise Server. A remote user can execute arbitrary code on the target system.

A remote user can send a specially crafted PDF file that, when opened by the target user on a BlackBerry smartphone that is associated with a user account on the target BlackBerry Enterprise Server, will trigger a buffer overflow in the PDF distiller component of the BlackBerry Attachment Service and execute arbitrary code on the target system. The code will run with the privileges of the target service.

The following versions are affected:

* BlackBerry Enterprise Server Express version 5.0.1 and 5.0.2 for Microsoft Exchange
* BlackBerry Enterprise Server Express version 5.0.2 for IBM Lotus Domino
* BlackBerry Enterprise Server versions 4.1.3 through 5.0.2 for Microsoft Exchange and IBM Lotus Domino
* BlackBerry Enterprise Server versions 4.1.3 through 5.0.1 for Novell GroupWise
* BlackBerry Professional Software version 4.1.4 for Microsoft Exchange and IBM Lotus Domino

Impact:   A remote user can execute arbitrary code on the target system.
Solution:   The vendor has issued a fix.

The vendor's advisory is available at:

http://www.blackberry.com/btsc/search.do?cmd=displayKC&docType=kc&externalId=KB24761

Vendor URL:  www.blackberry.com/btsc/search.do?cmd=displayKC&docType=kc&externalId=KB24761 (Links to External Site)
Cause:   Boundary error
Underlying OS:   Windows (2000), Windows (2003), Windows (2008)

Message History:   None.


 Source Message Contents

Date:  Wed, 15 Dec 2010 21:16:37 +0000
Subject:  Blackberry Enterprise Server


http://www.blackberry.com/btsc/search.do?cmd=displayKC&docType=kc&externalId=KB24761


 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC