SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (VPN)  >   strongSwan Vendors:   strongswan.org
strongSwan snprintf() Bug Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1024338
SecurityTracker URL:  http://securitytracker.com/id/1024338
CVE Reference:   CVE-2010-2628   (Links to External Site)
Date:  Aug 13 2010
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 4.3.3 to prior to 4.3.7, 4.4.0
Description:   A vulnerability was reported in strongSwan. A remote user can execute arbitrary code on the target system.

A remote user can supply specially crafted data to execute arbitrary code on the target system. The code will run with the privileges of the target service.

Impact:   A remote user can execute arbitrary code on the target system.
Solution:   The vendor has issued a fix (4.3.7, 4.4.1).

The vendor's advisory is available at:

https://lists.strongswan.org/pipermail/users/2010-August/005167.html

Vendor URL:  strongswan.org/ (Links to External Site)
Cause:   Access control error
Underlying OS:   Linux (Any), UNIX (Any)

Message History:   None.


 Source Message Contents

Date:  Fri, 13 Aug 2010 18:50:07 +0000
Subject:  strongSwan


[strongSwan] ANNOUNCE: strongswan-4.4.1 released



- snprintf vulnerability
   ----------------------

   A potential remote code execution vulnerability resulting from
   the misuse of snprintf() was fixed. The vulnerability was
   introduced with the strongswan-4.3.3 release and is exploitable
   by unauthenticated users. Patches for all releases starting with
   4.3.3 are available under the following link:

   http://download.strongswan.org/patches/08_snprintf_patch/

   Also a new 4.3.7 release has been made available for 4.3.x users

   http://www.strongswan.org/old.htm

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC