SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Database)  >   PostgreSQL Vendors:   postgresql.org
PostgreSQL Flaws in Safe.pm and PL/Perl Let Remote Authenticated Users Gain Elevated Privileges
SecurityTracker Alert ID:  1023988
SecurityTracker URL:  http://securitytracker.com/id/1023988
CVE Reference:   CVE-2010-1169, CVE-2010-1447   (Links to External Site)
Date:  May 18 2010
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 7.4.x, 8.0.x, 8.1.x, 8.2.x, 8.3.x, 8.4.x
Description:   A vulnerability was reported in PostgreSQL. A remote authenticated user can gain elevated privileges.

A remote authenticated user can exploit a flaw in Safe.pm and PL/Perl to execute arbitrary Perl code on the target database server.

Systems with PL/Perl installed and enabled are affected.

Impact:   A remote authenticated user can execute arbitrary Tcl code on the target database server.
Solution:   The vendor has issued a fix (7.4.29, 8.0.25, 8.1.21, 8.2.17, 8.3.11, 8.4.4).

The vendor's advisory is available at:

http://www.postgresql.org/about/news.1203

Vendor URL:  www.postgresql.org/about/news.1203 (Links to External Site)
Cause:   Not specified
Underlying OS:   Linux (Any), UNIX (Any), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
May 19 2010 (Red Hat Issues Fix) PostgreSQL Flaws in Safe.pm and PL/Perl Let Remote Authenticated Users Gain Elevated Privileges   (bugzilla@redhat.com)
Red Hat has issued a fix for Red Hat Enterprise Linux 5.
May 20 2010 (Red Hat Issues Fix) PostgreSQL Flaws in Safe.pm and PL/Perl Let Remote Authenticated Users Gain Elevated Privileges   (bugzilla@redhat.com)
Red Hat has issued a fix for Red Hat Enterprise Linux 4.
May 20 2010 (Red Hat Issues Fix) PostgreSQL Flaws in Safe.pm and PL/Perl Let Remote Authenticated Users Gain Elevated Privileges   (bugzilla@redhat.com)
Red Hat has issued a fix for Red Hat Enterprise Linux 3.
May 20 2010 (Red Hat Issues Fix) PostgreSQL Flaws in Safe.pm and PL/Perl Let Remote Authenticated Users Gain Elevated Privileges   (bugzilla@redhat.com)
Red Hat has issued a fix for postgresql84 for Red Hat Enterprise Linux 5.
Jun 7 2010 (Red Hat Issues Fix for Perl) PostgreSQL Flaws in Safe.pm and PL/Perl Let Remote Authenticated Users Gain Elevated Privileges   (bugzilla@redhat.com)
Red Hat has issued a fix for Perl for Red Hat Enterprise Linux 3 and 4.
Jun 8 2010 (Red Hat Issues Fix for Perl) PostgreSQL Flaws in Safe.pm and PL/Perl Let Remote Authenticated Users Gain Elevated Privileges   (bugzilla@redhat.com)
Red Hat has issued a fix for Perl for Red Hat Enterprise Linux 5.



 Source Message Contents

Date:  Tue, 18 May 2010 18:07:11 +0000
Subject:  PostgreSQL


CVE-2010-1169
CVE-2010-1447

A vulnerability in Safe.pm and PL/Perl can allow an authenticated user to run 
arbitrary Perl code on the database server if PL/Perl is installed and enabled.

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC