SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (File Transfer/Sharing)  >   Samba Vendors:   Samba.org
Samba smbd Processing Flaw Lets Remote Authenticated Users Deny Service
SecurityTracker Alert ID:  1022976
SecurityTracker URL:  http://securitytracker.com/id/1022976
CVE Reference:   CVE-2009-2906   (Links to External Site)
Date:  Oct 1 2009
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): versions prior to 3.0.37, 3.2.15, 3.3.8, 3.4.2
Description:   A vulnerability was reported in Samba. A remote authenticated user can cause denial of service conditions.

A remote authenticated user can send a specially crafted reply to an oplock break notification to cause the target smbd service to enter an infinite loop and consume excessive CPU resources.

Tim Prouty, Isilon, and the Samba Team reported this vulnerability.

Impact:   A remote authenticated user can cause the target smbd service to enter an infinite loop and consume excessive CPU resources.
Solution:   The vendor has issued a fix (3.0.37, 3.2.15, 3.3.8, 3.4.2).

The vendor's advisory is available at:

http://samba.org/samba/security/CVE-2009-2906.html

Vendor URL:  samba.org/samba/security/CVE-2009-2906.html (Links to External Site)
Cause:   State error
Underlying OS:   Linux (Any), UNIX (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Oct 27 2009 (Red Hat Issues Fix) Samba smbd Processing Flaw Lets Remote Authenticated Users Deny Service   (bugzilla@redhat.com)
Red Hat has released a fix for Red Hat Enterprise Linux 3.
Oct 27 2009 (Red Hat Issues Fix) Samba smbd Processing Flaw Lets Remote Authenticated Users Deny Service   (bugzilla@redhat.com)
Red Hat has released a fix for Red Hat Enterprise Linux 4 and 5.
Nov 16 2009 (Red Hat Issues Fix) Samba smbd Processing Flaw Lets Remote Authenticated Users Deny Service   (bugzilla@redhat.com)
Red Hat has issued a fix for Red Hat Enterprise Linux 5 Supplementary.
Nov 19 2009 (Sun Issues Fix) Samba smbd Processing Flaw Lets Remote Authenticated Users Deny Service
Sun has issued a fix for Solaris.
Apr 2 2010 (VMware Issues Fix for ESX) Samba smbd Processing Flaw Lets Remote Authenticated Users Deny Service   (VMware Security Team <security@vmware.com>)
VMware has issued a fix for VMware ESX.



 Source Message Contents

Date:  Thu, 1 Oct 2009 14:51:10 -0400
Subject:  Samba


http://samba.org/samba/security/CVE-2009-2906.html

CVE-2009-2906
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC