SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (E-mail Client)  >   Mozilla Thunderbird Vendors:   Mozilla.org
Mozilla Thunderbird Bugs Let Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1022397
SecurityTracker URL:  http://securitytracker.com/id/1022397
CVE Reference:   CVE-2009-1392, CVE-2009-1832, CVE-2009-1833, CVE-2009-1838, CVE-2009-1841   (Links to External Site)
Date:  Jun 12 2009
Impact:   Execution of arbitrary code via network, User access via network
Vendor Confirmed:  Yes  
Version(s): prior to 2.0.0.22
Description:   A vulnerability was reported in Mozilla Thunderbird. A remote user can cause arbitrary code to be executed on the target user's system.

A remote user can send specially crafted e-mail that, when loaded by the target user, will execute arbitrary code on the target system [CVE-2009-1392, CVE-2009-1832, CVE-2009-1833, CVE-2009-1838]. The code will run with the privileges of the target user. Thunderbird is affected if JavaScript is enabled [not the default configuration].

A remote user can send specially crafted e-mail that, when loaded by the target user, will execute arbitrary scripting code with chrome privileges on the target user's system [CVE-2009-1841]. The system is not vulnerable in the default configuration. The system may be vulnerable if the user has installed an add-on which adds a similarly implemented feature and then enables JavaScript in mail messages.

Impact:   A remote user can create an e-mail message that, when loaded by the target user, will execute arbitrary code on the target user's system.
Solution:   No solution was available at the time of this entry.

The vendor plans to include a fix in version 2.0.0.22.

The vendor's advisories are available at:

http://www.mozilla.org/security/announce/2009/mfsa2009-24.html
http://www.mozilla.org/security/announce/2009/mfsa2009-29.html
http://www.mozilla.org/security/announce/2009/mfsa2009-32.html

Vendor URL:  www.mozilla.org/security/announce/2009/mfsa2009-24.html (Links to External Site)
Cause:   Access control error
Underlying OS:   Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Date:  Fri, 12 Jun 2009 00:23:39 -0400
Subject:  Mozilla Thunderbird


http://www.mozilla.org/security/announce/2009/mfsa2009-24.html
http://www.mozilla.org/security/announce/2009/mfsa2009-29.html
http://www.mozilla.org/security/announce/2009/mfsa2009-32.html

CVE-2009-1392
CVE-2009-1832
CVE-2009-1833
CVE-2009-1838
CVE-2009-1841
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC