SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Device (Router/Bridge/Hub)  >   F5 FirePass Vendors:   F5 Networks
F5 FirePass Input Validation Flaw in Unspecified Password Fields Permits Cross-Site Scripting Attacks
SecurityTracker Alert ID:  1022387
SecurityTracker URL:  http://securitytracker.com/id/1022387
CVE Reference:   CVE-2009-2119   (Links to External Site)
Updated:  Jun 23 2009
Original Entry Date:  Jun 12 2009
Impact:   Disclosure of authentication information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to HotFix-603-3
Description:   A vulnerability was reported in F5 FirePass. A remote user can conduct cross-site scripting attacks.

A remote user can create a specially crafted URL that, when loaded by a target user, will cause arbitrary scripting code to be executed by the target user's browser. The code will originate from the F5 FirePass device and will run in the security context of that site. As a result, the code will be able to access the target user's cookies (including authentication cookies), if any, associated with the site, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

Unspecified password fields are affected.

The vendor was notified on May 14, 2009.

Sjoerd Resink of Fox-IT BV reported this vulnerability.

The original advisory is available at:

https://www.fox-it.com/nl/nieuws-en-events/nieuws/laatste-nieuws/nieuwsartikel/f5-firepass-cross-site-scripting-vulnerability/106

Impact:   A remote user can access the target user's cookies (including authentication cookies), if any, associated with the F5 FirePass device, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.
Solution:   The vendor has issued a fix (Cumulative HotFix-603-3).

The vendor's advisory is available at:

https://support.f5.com/kb/en-us/solutions/public/10000/100/sol10143.html

Vendor URL:  www.f5.com/products/firepass/ (Links to External Site)
Cause:   Input validation error
Underlying OS:  

Message History:   None.


 Source Message Contents

Date:  Thu, 11 Jun 2009 23:51:02 -0400
Subject:  F5 FirePass


https://www.fox-it.com/nl/nieuws-en-events/nieuws/laatste-nieuws/nieuwsartikel/f5-firepass-cross-site-scripting-vulnerability/106

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC