SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   Sun Java System Portal Server Vendors:   Sun
Sun Java System Portal Server Input Validation Bug in Error Page Permits Cross-Site Scripting Attacks
SecurityTracker Alert ID:  1022273
SecurityTracker URL:  http://securitytracker.com/id/1022273
CVE Reference:   CVE-2009-1796   (Links to External Site)
Updated:  Jun 8 2009
Original Entry Date:  May 25 2009
Impact:   Disclosure of authentication information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 6.3.1, 7.1, 7.2
Description:   A vulnerability was reported in Sun Java System Portal Server. A remote user can conduct cross-site scripting attacks.

The error page does not properly filter HTML code from user-supplied input before displaying the input. A remote user can create a specially crafted URL that, when loaded by a target user, will cause arbitrary scripting code to be executed by the target user's browser. The code will originate from the site running the Sun Java System Portal Server software and will run in the security context of that site. As a result, the code will be able to access the target user's cookies (including authentication cookies), if any, associated with the site, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

Impact:   A remote user can access the target user's cookies (including authentication cookies), if any, associated with the site running the Sun Java System Portal Server software, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.
Solution:   The vendor has issued a fix.

SPARC Platform

* Sun Java System Portal Server 6.3.1 (for Solaris 8, 9, and 10) with patch 118950-38 or later
* Sun Java System Portal Server 7.1 (for Solaris 9 and 10) with patch 124301-13 or later
* Sun Java System Portal Server 7.2 (for Solaris 9 and 10) with patch 138686-02 or later

x86 Platform

* Sun Java System Portal Server 6.3.1 (for Solaris 8, 9, and 10) with patch 118951-38 or later
* Sun Java System Portal Server 7.1 (for Solaris 9 and 10) with patch 124302-13 or later
* Sun Java System Portal Server 7.2 (for Solaris 9 and 10) with patch 138687-02 or later

Linux

* Sun Java System Portal Server 6.3.1 with patch 118952-38 or later
* Sun Java System Portal Server 7.1 with patch 124303-13 or later
* Sun Java System Portal Server 7.2 with patch 138688-02 or later

The vendor's advisory is available at:

http://sunsolve.sun.com/search/document.do?assetkey=1-66-256588-1

Vendor URL:  sunsolve.sun.com/search/document.do?assetkey=1-66-256588-1 (Links to External Site)
Cause:   Input validation error
Underlying OS:   Linux (Any), UNIX (Solaris - SunOS)

Message History:   None.


 Source Message Contents

Date:  Sun, 24 May 2009 23:54:06 -0400
Subject:  A Cross-Site Scripting (XSS) Vulnerability in Sun Java System Portal Server's Error Page May Lead to Execution of Arbitrary Code


http://sunsolve.sun.com/search/document.do?assetkey=1-66-256588-1
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC