SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   Xpdf Vendors:   Glyph and Cog
Xpdf JBIG2 Decoder Bugs Let Remote Users Deny Service
SecurityTracker Alert ID:  1022072
SecurityTracker URL:  http://securitytracker.com/id/1022072
CVE Reference:   CVE-2009-0799, CVE-2009-1181, CVE-2009-1183   (Links to External Site)
Date:  Apr 17 2009
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 3.02
Description:   Several vulnerabilities were reported in Xpdf. A remote user can cause denial of service conditions.

A remote user can create a specially crafted PDF file that, when processed by the target user or application, will trigger a flaw in the JBIG2 decoder and cause the application using xpdf to crash.

Will Dormann of the CERT/CC created the JBIG2 decoder testsuite that was used to discover these vulnerabilities.

Impact:   A remote user can cause the target application to crash.
Solution:   The vendor has issued a patch, available at:

ftp://ftp.foolabs.com/pub/xpdf/xpdf-3.02pl3.patch

Vendor URL:  www.foolabs.com/xpdf/ (Links to External Site)
Cause:   Access control error
Underlying OS:   Linux (Any), UNIX (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Apr 17 2009 (Red Hat Issues Fix) Xpdf JBIG2 Decoder Bugs Let Remote Users Deny Service   (bugzilla@redhat.com)
Red Hat has released a fix for Red Hat Enterprise Linux 3 and 4.
Apr 17 2009 (Red Hat Issues Fix for CUPS) Xpdf JBIG2 Decoder Bugs Let Remote Users Deny Service   (bugzilla@redhat.com)
Red Hat has released a fix for CUPS for Red Hat Enterprise Linux 4 and 5.
Apr 17 2009 (Red Hat Issues Fix for kdegraphics) Xpdf JBIG2 Decoder Bugs Let Remote Users Deny Service   (bugzilla@redhat.com)
Red Hat has released a fix kdegraphics for Red Hat Enterprise Linux 4 and 5.
Apr 30 2009 (Red Hat Issues Fix for gpdf) Xpdf JBIG2 Decoder Bugs Let Remote Users Deny Service   (bugzilla@redhat.com)
Red Hat has released a fix for gpdf for Red Hat Enterprise Linux 4.



 Source Message Contents

Date:  Thu, 16 Apr 2009 20:37:51 -0400
Subject:  xpdf


Multiple denial of service flaws were found in Xpdf's JBIG2 decoder. An
attacker could create a malicious PDF that would cause Xpdf to crash when
opened. (CVE-2009-0799, CVE-2009-1181, CVE-2009-1183)

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC