SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   Libxml2 Vendors:   xmlsoft.org
Libxml2 Integer Overflow in xmlBufferResize() Lets Remote Users Deny Service
SecurityTracker Alert ID:  1021239
SecurityTracker URL:  http://securitytracker.com/id/1021239
CVE Reference:   CVE-2008-4225   (Links to External Site)
Date:  Nov 17 2008
Impact:   Denial of service via network, Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 2.7.2 and prior versions
Description:   A vulnerability was reported in Libxml2. A remote user can cause denial of service conditions.

A remote user can create specially crafted XML that, when loaded by the target application using libxml2, will trigger an integer overflow in the xmlBufferResize() function and cause the application to enter an infinite loop.

The vulnerability resides in 'tree.c'.

Drew Yao of Apple Product Security reported this vulnerability.

Impact:   A remote user can cause denial of service conditions.
Solution:   The vendor has issued a source code fix, available via SVN.
Vendor URL:  xmlsoft.org/ (Links to External Site)
Cause:   Boundary error, State error
Underlying OS:   Linux (Any), UNIX (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Nov 17 2008 (Red Hat Issues Fix) Libxml2 Integer Overflow in xmlBufferResize() Lets Remote Users Deny Service   (bugzilla@redhat.com)
Red Hat has released a fix for Red Hat Enterprise Linux 2.1, 3, 4, and 5.
Feb 2 2009 (VMware Issues Fix for ESX) Libxml2 Integer Overflow in xmlBufferResize() Lets Remote Users Deny Service   (VMware Security Team <security@vmware.com>)
VMware has issued a fix for ESX.
Feb 4 2009 (Sun Issues Fix) Libxml2 Integer Overflow in xmlBufferResize() Lets Remote Users Deny Service
Sun has issued a fix for OpenSolaris.
Aug 10 2009 (Sun Issues fix for Sun Java System Access Manager) Libxml2 Integer Overflow in xmlBufferResize() Lets Remote Users Deny Service
Sun has issued a fix for Sun Java System Access Manager Policy Agent.



 Source Message Contents

Date:  Mon, 17 Nov 2008 16:42:44 -0500
Subject:  Libxml2


A denial of service flaw was discovered in the libxml2 XML parser. If an
application linked against libxml2 processed untrusted, malformed XML
content, it could cause the application to enter an infinite loop.
(CVE-2008-4225)

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC