SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   CUPS Vendors:   Easy Software Products
CUPS Heap Overflow in 'texttops' Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1021034
SecurityTracker URL:  http://securitytracker.com/id/1021034
CVE Reference:   CVE-2008-3640   (Links to External Site)
Date:  Oct 10 2008
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 1.3.9
Description:   A vulnerability was reported in CUPS. A remote user can execute arbitrary code on the target system.

A remote user can send a specially crafted text file to the CUPS service to trigger a heap overflow and execute arbitrary code on the target system. The code will run with the 'lp' user privileges.

The vulnerability resides in the Text-to-PostScript "texttops" filter WriteProlog() function.

regenrecht reported this vulnerability.

Impact:   A remote user can execute arbitrary code on the target system.
Solution:   The vendor has issued a fixed version (1.3.9).

The vendor's advisory is available at:

http://cups.org/articles.php?L575

Vendor URL:  www.cups.org/ (Links to External Site)
Cause:   Boundary error
Underlying OS:   Linux (Any), UNIX (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Oct 10 2008 (Red Hat Issues Fix) CUPS Heap Overflow in 'texttops' Lets Remote Users Execute Arbitrary Code   (bugzilla@redhat.com)
Red Hat has released a fix for Red Hat Enterprise Linux 3, 4, and 5.
Jun 11 2009 (Sun Issues Fix) CUPS Heap Overflow in 'texttops' Lets Remote Users Execute Arbitrary Code
Sun has issued a fix for OpenSolaris.



 Source Message Contents

Date:  Fri, 10 Oct 2008 06:24:55 -0400
Subject:  Common UNIX Printing System (CUPS)


An integer overflow flaw leading to a heap buffer overflow was discovered
in the Text-to-PostScript "texttops" filter. An attacker could create a
malicious text file that could, possibly, execute arbitrary code as the
"lp" user if the file was printed. (CVE-2008-3640)

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC