SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Directory)  >   Novell eDirectory Vendors:   Novell
Novell eDirectory Heap Overflow in Processing Certain Opcodes Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1020990
SecurityTracker URL:  http://securitytracker.com/id/1020990
CVE Reference:   CVE-2008-4478, CVE-2008-4480   (Links to External Site)
Updated:  Oct 9 2008
Original Entry Date:  Oct 3 2008
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 8.7.3
Description:   A vulnerability was reported in Novell eDirectory. A remote user may be able to execute arbitrary code on the target system.

A remote user can send specially crafted data to trigger a heap overflow and potentially execute arbitrary code on the target system. The code will run with the privileges of the target service.

Specially crafted update replica verbs (Opcode 0x23 & 0x24) can trigger a heap overflow.

A specially crafted DSV_READ verb (Opcode 0x0F) can trigger a heap overflow.

The vendor was notified on May 19, 2008.

Sebastian Apelt reported this vulnerability via ZDI.

Impact:   A remote user may be able to execute arbitrary code on the target system.
Solution:   The vendor has issued a fixed version (8.7.3 SP10 FTF1).

The vendor's advisory is available at:

http://www.novell.com/support/viewContent.do?externalId=3477912

Vendor URL:  www.novell.com/support/viewContent.do?externalId=3477912 (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Any), UNIX (Solaris - SunOS), Windows (2000), Windows (2003)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2017, SecurityGlobal.net LLC