SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   Rails Vendors:   rubyforge.org
Ruby on Rails Input Validation Flaw in ':limit' and ':offset' Parameters Lets Remote Users Inject SQL Commands
SecurityTracker Alert ID:  1020871
SecurityTracker URL:  http://securitytracker.com/id/1020871
CVE Reference:   CVE-2008-4094   (Links to External Site)
Updated:  Aug 20 2009
Original Entry Date:  Sep 15 2008
Impact:   Disclosure of system information, Disclosure of user information, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 2.1.1
Description:   A vulnerability was reported in Rails. A remote user can inject SQL commands.

The software does not properly validate user-supplied input in the ':limit' and ':offset' parameters. If an application uses unfiltered user-supplied input in making calls with those parameters, a remote user can supply a specially crafted parameter value to execute SQL commands on the underlying database.

The original advisory is available at:

http://blog.innerewut.de/2008/6/16/why-you-should-upgrade-to-rails-2-1

Jonathan Weiss reported this vulnerability.

Impact:   A remote user can execute SQL commands on the underlying database.
Solution:   The vendor has issued a fix (2.1.1), available at:

http://www.rubyonrails.org/down

Patches for 1.2 and 2.0 are available at:

http://rails.lighthouseapp.com/projects/8994/tickets/964

Vendor URL:  www.rubyonrails.org/ (Links to External Site)
Cause:   Input validation error
Underlying OS:   Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Date:  Mon, 15 Sep 2008 09:29:04 -0400
Subject:  Rails


> SQL Injection for :limit and :offset 

http://rails.lighthouseapp.com/projects/8994/tickets/288
http://rails.lighthouseapp.com/projects/8994/tickets/964
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC