SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   IBM Tivoli Provisioning Manager Vendors:   IBM
IBM Tivoli Provisioning Manager for OS Deployment Buffer Overflow Lets Remote Users Deny Service and Potentially Execute Arbitrary Code
SecurityTracker Alert ID:  1019249
SecurityTracker URL:  http://securitytracker.com/id/1019249
CVE Reference:   CVE-2008-0401   (Links to External Site)
Updated:  Jan 24 2008
Original Entry Date:  Jan 22 2008
Impact:   Denial of service via network, Execution of arbitrary code via network, Root access via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 5.1.0.3
Description:   A vulnerability was reported in IBM Tivoli Provisioning Manager for OS Deployment. A remote user can cause denial of service conditions. A remote user can potentially execute arbitrary code on the target system.

A remote user can supply an HTTP request with a specially crafted HTTP request method to trigger a buffer overflow in the web server's logging component. This may cause denial of service conditions on the HTTP server or may permit arbitrary code execution.

An anonymous researcher reported this vulnerability via iDefense.

The vendor was notified on October 24, 2007.

[Editor's note: The vendor indicated this was a denial of service vulnerability. iDefense indicated that this allows remote users to "potentially execute arbitrary code." The iDefense report did not confirm code execution.]

Impact:   A remote user can cause denial of service conditions.

A remote user can potentially execute arbitrary code on the target system.

Solution:   The vendor has issued a fix (5.1.0.3 Interim Fix 3).

The IBM advisory is available at:

http://www-1.ibm.com/support/docview.wss?uid=swg24018010

Vendor URL:  www-1.ibm.com/support/docview.wss?uid=swg24018010 (Links to External Site)
Cause:   Boundary error
Underlying OS:   Linux (Any), UNIX (Solaris - SunOS), Windows (2003)

Message History:   None.


 Source Message Contents

Date:  Tue, 22 Jan 2008 10:56:41 -0500
Subject:  Tivoli Provisioning Manager for OS Deployment


http://www-1.ibm.com/support/docview.wss?uid=swg24018010


> Fixed a Denial Of Service vulnerability on HTTP server (iDefense Vendor Notification [IDEF2750])
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC