SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   HP OpenView Vendors:   HP (Compaq)
HP OpenView Configuration Management (CM) Infrastructure (Radia) and Client Configuration Manager Lets Remote Users Access Data
SecurityTracker Alert ID:  1018858
SecurityTracker URL:  http://securitytracker.com/id/1018858
CVE Reference:   CVE-2007-5413   (Links to External Site)
Updated:  Nov 1 2007
Original Entry Date:  Oct 24 2007
Impact:   Disclosure of system information, Disclosure of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): HP OpenView CM Radia 4.0, 4.1, 4.2, 4.2i; OpenView CCM 2.0
Description:   A vulnerability was reported in HP OpenView Configuration Management Infrastructure and Client Configuration Manager. A remote user can access files on the target system.

A remote user can supply a specially crafted URL containing path names (e.g., '-root') to 'httpd.tkd' to gain access to files on the target system.

The vendor was notified on December 18, 2006.

TippingPoint reported this vulnerability.

Impact:   A remote user can access files on the target system.
Solution:   HP has issued the following fixes.

CM Infrastructure v4.0
AIX
RADINFRAAIX_00008 or subsequent
http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAAIX_00008

CM Infrastructure v4.0
HP-UX B.11.00
RADINFRAHPUX1_00009 or subsequent
http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAHPUX1_00009

CM Infrastructure v4.0
HP-UX B.11.11
RADINFRAHPUX1_00009or or subsequent
http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAHPUX1_00009

CM Infrastructure v4.0
HP-UX B.11.23
RADINFRAHPUX1_00009 or subsequent
http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAHPUX1_00009

CM Infrastructure v4.0
Linux
RADINFRALNX_00007 or subsequent
http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRALNX_00007

CM Infrastructure v4.0
Solaris
RADINFRASOL_00009 or subsequent
http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRASOL_00009

CM Infrastructure v4.0
Win32
RADINFRAWIN32_00023 or subsequent
http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAWIN32_00023

CM Infrastructure v4.0i
Win32
RADINFRAWIN32_00024 or subsequent
http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAWIN32_00024

CM Infrastructure v4.1
AIX
RADINFRAAIX_00009 or subsequent
http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAAIX_00009

CM Infrastructure v4.1
HP-UX B.11.00
RADINFRAHPUX1_00010 or subsequent
http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAHPUX1_00010

CM Infrastructure v4.1
HP-UX B.11.11
RADINFRAHPUX1_00010 or subsequent
http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAHPUX1_00010

CM Infrastructure v4.1
HP-UX B.11.23
RADINFRAHPUX1_00010 or subsequent
http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAHPUX1_00010

CM Infrastructure v4.1
Linux
RADINFRALNX_00008 or subsequent
http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRALNX_00008

CM Infrastructure v4.1
Solaris
RADINFRASOL_00010 or subsequent
http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRASOL_00010

CM Infrastructure v4.1
Win32
RADINFRAWIN32_00025 or subsequent
http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAWIN32_00025

CM Infrastructure v4.2
AIX
RADINFRAAIX_00010 or subsequent
http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAAIX_00010

CM Infrastructure v4.2
HP-UX B.11.00
RADINFRAHPUX1_00011 or subsequent
http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAHPUX1_00011

CM Infrastructure v4.2
HP-UX B.11.11
RADINFRAHPUX1_00011 or subsequent
http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAHPUX1_00011

CM Infrastructure v4.2
HP-UX B.11.23
RADINFRAHPUX1_00011 or subsequent
http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAHPUX1_00011

CM Infrastructure v4.2
Linux
RADINFRALNX_00009 or subsequent
http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRALNX_00009

CM Infrastructure v4.2
Solaris
RADINFRASOL_00011 or subsequent
http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRASOL_00011

CM Infrastructure v4.2
Win32
RADINFRAWIN32_00026 or subsequent
http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAWIN32_00026

CM Infrastructure v4.2 with Patch 3.0.3
Win32
RADINFRAWIN32_00027 or subsequent
http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAWIN32_00027

CM Infrastructure v4.2i
Win32
RADINFRAWIN32_00028 or subsequent
http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAWIN32_00028

CCM Infrastructure v2.0
Win32
CCM_00005 or subsequent
http://openview.hp.com/ecare/getsupportdoc?docid=CCM_00005

Vendor URL:  www.hp.com/ (Links to External Site)
Cause:   Access control error, Input validation error
Underlying OS:   Linux (Any), UNIX (AIX), UNIX (HP/UX), UNIX (Solaris - SunOS), Windows (Any)

Message History:   None.


 Source Message Contents

Date:  Wed, 24 Oct 2007 06:45:55 -0700
Subject:  HPSBMA02279 SSRT071298 rev.1 - HP OpenView Configuration Management (CM) Infrastructure (Radia) and Client Configuration

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

SUPPORT COMMUNICATION - SUPPORT COMMUNICATION - SECURITY BULLETIN

Document ID: c01205079
Version: 1

HPSBMA02279 SSRT071298 rev.1 - HP OpenView Configuration Management (CM) Infrastructure (Radia) and Client Configuration Manager (CCM)
 Running httpd.tkd, Remote Unauthorized Access to Data

NOTICE: The information in this Security Bulletin should be acted upon as soon as possible.

Release Date: 2007-10-23
Last Updated: 2007-10-23

Potential Security Impact: Remote unauthorized access to data

Source: Hewlett-Packard Company, HP Software Security Response Team

VULNERABILITY SUMMARY
A potential vulnerability has been identified with HP OpenView Configuration Management (CM) Infrastructure (Radia) and Client Configuration
 Manager (CCM) running httpd.tkd. The vulnerability could be exploited to allow remote unauthorized access to data.

References: CVE-2007-5413

SUPPORTED SOFTWARE VERSIONS*: ONLY impacted versions are listed.
HP OpenView Configuration Management (CM) Infrastructure (Radia) v4.0, v4.1, v4.2, v4.2i running httpd.tkd on Windows, HP-UX, AIX,
 Solaris, and Linux. 
HP OpenView Client Configuration Manager (CCM) v2.0 running httpd.tkd on Windows. 

BACKGROUND

The Hewlett-Packard Company thanks an anonymous researcher working with TippingPoint (www.tippingpoint.com) and the Zero Day Initiative
 (www.zerodayinitiative.com) for reporting this to security-alert@hp.com.

Note: The httpd.tkd module is used by several OpenView Configuration Management (CM) and OpenView Client Configuration Management
 (CCM) Infrastructure components. These components include OS Manager, Policy Server, Portal, Patch Manager, Proxy Server, Distributed
 Configuration Server and Multicast Server. There may be more than one httpd.tkd module on a system. Each must be replaced. Please
 refer to the patch documentation for further information. 

Note: The following is for use by the HP-UX Software Assistant. Only the HP-UX versions are listed 

AFFECTED VERSIONS

For CM infrastructure (Radia) v4.0

HP-UX B.11.00 
HP-UX B.11.11 
HP-UX B.11.23 
============= 
action: install RADINFRAHPUX1_00009 or subsequent 
URL: http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAHPUX1_00009 

For CM infrastructure (Radia) v4.1

HP-UX B.11.00 
HP-UX B.11.11 
HP-UX B.11.23 
============= 
action: install RADINFRAHPUX1_00010 or subsequent 
URL: http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAHPUX1_00010 

For CM infrastructure (Radia) v4.2

HP-UX B.11.00 
HP-UX B.11.11 
HP-UX B.11.23 
============= 
action: install RADINFRASOL_00011 or subsequent 
URL: http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRASOL_00011 

End Affected Versions

RESOLUTION
HP has provided the following patches to resolve this vulnerability. 
The patches and installation instructions are available from the URL's listed below. 

Product
 Platform
 Patch ID
 URL
 
CM Infrastructure v4.0
 AIX
 RADINFRAAIX_00008 or subsequent
 http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAAIX_00008 
 
CM Infrastructure v4.0
 HP-UX B.11.00
 RADINFRAHPUX1_00009 or subsequent
 http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAHPUX1_00009 
 
CM Infrastructure v4.0
 HP-UX B.11.11
 RADINFRAHPUX1_00009or or subsequent
 http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAHPUX1_00009 
 
CM Infrastructure v4.0
 HP-UX B.11.23
 RADINFRAHPUX1_00009 or subsequent
 http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAHPUX1_00009 
 
CM Infrastructure v4.0
 Linux
 RADINFRALNX_00007 or subsequent
 http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRALNX_00007 
 
CM Infrastructure v4.0
 Solaris
 RADINFRASOL_00009 or subsequent
 http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRASOL_00009 
 
CM Infrastructure v4.0
 Win32
 RADINFRAWIN32_00023 or subsequent
 http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAWIN32_00023 
 
CM Infrastructure v4.0i
 Win32
 RADINFRAWIN32_00024 or subsequent
 http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAWIN32_00024 
 
CM Infrastructure v4.1
 AIX
 RADINFRAAIX_00009 or subsequent
 http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAAIX_00009 
 
CM Infrastructure v4.1
 HP-UX B.11.00
 RADINFRAHPUX1_00010 or subsequent
 http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAHPUX1_00010 
 
CM Infrastructure v4.1
 HP-UX B.11.11
 RADINFRAHPUX1_00010 or subsequent
 http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAHPUX1_00010 
 
CM Infrastructure v4.1
 HP-UX B.11.23
 RADINFRAHPUX1_00010 or subsequent
 http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAHPUX1_00010 
 
CM Infrastructure v4.1
 Linux
 RADINFRALNX_00008 or subsequent
 http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRALNX_00008 
 
CM Infrastructure v4.1
 Solaris
 RADINFRASOL_00010 or subsequent
 http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRASOL_00010 
 
CM Infrastructure v4.1
 Win32
 RADINFRAWIN32_00025 or subsequent
 http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAWIN32_00025 
 
CM Infrastructure v4.2
 AIX
 RADINFRAAIX_00010 or subsequent
 http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAAIX_00010 
 
CM Infrastructure v4.2
 HP-UX B.11.00
 RADINFRAHPUX1_00011 or subsequent
 http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAHPUX1_00011 
 
CM Infrastructure v4.2
 HP-UX B.11.11
 RADINFRAHPUX1_00011 or subsequent
 http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAHPUX1_00011 
 
CM Infrastructure v4.2
 HP-UX B.11.23
 RADINFRAHPUX1_00011 or subsequent
 http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAHPUX1_00011 
 
CM Infrastructure v4.2
 Linux
 RADINFRALNX_00009 or subsequent
 http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRALNX_00009 
 
CM Infrastructure v4.2
 Solaris
 RADINFRASOL_00011 or subsequent
 http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRASOL_00011 
 
CM Infrastructure v4.2
 Win32
 RADINFRAWIN32_00026 or subsequent
 http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAWIN32_00026 
 
CM Infrastructure v4.2 with Patch 3.0.3 
 Win32
 RADINFRAWIN32_00027 or subsequent
 http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAWIN32_00027 
 
CM Infrastructure v4.2i
 Win32
 RADINFRAWIN32_00028 or subsequent
 http://openview.hp.com/ecare/getsupportdoc?docid=RADINFRAWIN32_00028 
 
CCM Infrastructure v2.0
 Win32
 CCM_00005 or subsequent
 http://openview.hp.com/ecare/getsupportdoc?docid=CCM_00005 
 
MANUAL ACTION: Yes - Update 
CM Infrastructure v4.0 HP-UX B.11.00 install RADINFRAHPUX1_00009 or subsequent 
CM Infrastructure v4.0 HP-UX B.11.11 install RADINFRAHPUX1_00009 or subsequent 
CM Infrastructure v4.0 HP-UX B.11.23 install RADINFRAHPUX1_00009 or subsequent 
CM Infrastructure v4.1 HP-UX B.11.00 install RADINFRAHPUX1_00010 or subsequent 
CM Infrastructure v4.1 HP-UX B.11.11 install RADINFRAHPUX1_00010 or subsequent 
CM Infrastructure v4.1 HP-UX B.11.23 install RADINFRAHPUX1_00010 or subsequent 
CM Infrastructure v4.2 HP-UX B.11.00 install RADINFRAHPUX1_00011 or subsequent 
CM Infrastructure v4.2 HP-UX B.11.11 install RADINFRAHPUX1_00011 or subsequent 
CM Infrastructure v4.2 HP-UX B.11.23 install RADINFRAHPUX1_00011 or subsequent 

HISTORY 
Version: 1 (rev.1) 23 October 2007 Initial release 

Support: For further information, contact normal HP Services support channel.

Report: To report a potential security vulnerability with any HP supported product, send Email to: security-alert@hp.com 
It is strongly recommended that security related information being communicated to HP be encrypted using PGP, especially exploit information.
 
To get the security-alert PGP key, please send an e-mail message as follows:
  To: security-alert@hp.com 
  Subject: get key

Subscribe: To initiate a subscription to receive future HP Security Bulletins via Email: 
http://h30046.www3.hp.com/driverAlertProfile.php?regioncode=NA&langcode=USENG&jumpid=in_SC-GEN__driverITRC&topiccode=ITRC 
On the web page: ITRC security bulletins and patch sign-up 
Under Step1: your ITRC security bulletins and patches 
    -check ALL categories for which alerts are required and continue.
Under Step2: your ITRC operating systems 
    -verify your operating system selections are checked and save.


To update an existing subscription: http://h30046.www3.hp.com/subSignIn.php 
Log in on the web page: Subscriber's choice for Business: sign-in. 
On the web page: Subscriber's Choice: your profile summary - use Edit Profile to update appropriate sections.


To review previously published Security Bulletins visit: http://www.itrc.hp.com/service/cki/secBullArchive.do 


* The Software Product Category that this Security Bulletin relates to is represented by the 5th and 6th characters of the Bulletin
 number in the title:

GN = HP General SW
MA = HP Management Agents
MI = Misc. 3rd Party SW
MP = HP MPE/iX
NS = HP NonStop Servers
OV = HP OpenVMS
PI = HP Printing & Imaging
ST = HP Storage SW
TL = HP Trusted Linux
TU = HP Tru64 UNIX
UX = HP-UX
VV = HP VirtualVault
 

System management and security procedures must be reviewed frequently to maintain system integrity. HP is continually reviewing and
 enhancing the security features of software products to provide customers with current secure solutions.


"HP is broadly distributing this Security Bulletin in order to bring to the attention of users of the affected HP products the important
 security information contained in this Bulletin. HP recommends that all users determine the applicability of this information to
 their individual situations and take appropriate action. HP does not warrant that this information is necessarily accurate or complete
 for all user situations and, consequently, HP will not be responsible for any damages resulting from user's use or disregard of the
 information provided in this Bulletin. To the extent permitted by law, HP disclaims all warranties, either express or implied, including
 the warranties of merchantability and fitness for a particular purpose, title and non-infringement."

ęCopyright 2007 Hewlett-Packard Development Company, L.P. 

Hewlett-Packard Company shall not be liable for technical or editorial errors or omissions contained herein. The information provided
 is provided "as is" without warranty of any kind. To the extent permitted by law, neither HP or its affiliates, subcontractors or
 suppliers will be liable for incidental,special or consequential damages including downtime cost; lost profits;damages relating to
 the procurement of substitute products or services; or damages for loss of data, or software restoration. The information in this
 document is subject to change without notice. Hewlett-Packard Company and the names of Hewlett-Packard products referenced herein
 are trademarks of Hewlett-Packard Company in the United States and other countries. Other product and company names mentioned herein
 may be trademarks of their respective owners.
-----BEGIN PGP SIGNATURE-----
Version: PGP 8.1

iQA/AwUBRx9AJOAfOvwtKn1ZEQI1EwCg1X7GytZhNxOdpx2kyCoLYs5wfwkAn1oQ
ICvhmNByAq3BOIE0StuYFyfb
=nHXo
-----END PGP SIGNATURE-----

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC