SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   OS (UNIX)  >   Mac OS X Vendors:   Apple Computer
Apple Installer Format String Bug Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1017940
SecurityTracker URL:  http://securitytracker.com/id/1017940
CVE Reference:   CVE-2007-0465   (Links to External Site)
Date:  Apr 20 2007
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 10.4.x
Description:   A vulnerability was reported in Apple Installer. A remote user can cause arbitrary code to be executed on the target user's system.

A remote user can create a pkg, distz, or mpkg package file with a specially crafted filename that, when loaded by the target user, will trigger a format string flaw and execute arbitrary code on the target system. The code will run with the privileges of the target user.

Systems prior to version 10.4 are not affected.

LMH discovered this vulnerability.

The original advisory is available at:

http://projects.info-pull.com/moab/MOAB-26-01-2007.html

Impact:   A remote user can create a file that, when loaded by the target user, will execute arbitrary code on the target user's system.
Solution:   Apple has released a fix for Mac OS X as part of Security Update 2007-004, available from the Software Update pane in System Preferences, or Apple's Software Downloads web site at:

http://www.apple.com/support/downloads/

For Mac OS X v10.4.9 (PowerPC) and Mac OS X Server v10.4.9 (PowerPC)
The download file is named: "SecUpd2007-004Ti.dmg"
Its SHA-1 digest is: 710afb28b12113a6b6570c36d4a87302cc5b4d8c

For Mac OS X v10.4.9 (Universal) and
Mac OS X Server v10.4.9 (Universal)
The download file is named: "SecUpd2007-004Univ.dmg"
Its SHA-1 digest is: 6d6c39a7068bfbf403da493f49ed23a5b10bc6bb

The Apple advisory is available at:

http://docs.info.apple.com/article.html?artnum=305391

Vendor URL:  docs.info.apple.com/article.html?artnum=305391 (Links to External Site)
Cause:   Input validation error, State error
Underlying OS:  

Message History:   None.


 Source Message Contents

Date:  Thu, 19 Apr 2007 23:46:07 -0400
Subject:  Mac OS X


CVE-2007-0465

http://projects.info-pull.com/moab/MOAB-26-01-2007.html


 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC