SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Multimedia)  >   SHOUTcast Vendors:   Nullsoft
SHOUTcast Validation Logic Error Lets Remote Users View Files on the Target System
SecurityTracker Alert ID:  1016493
SecurityTracker URL:  http://securitytracker.com/id/1016493
CVE Reference:   CVE-2006-3534, CVE-2006-3535   (Links to External Site)
Updated:  Jul 18 2008
Original Entry Date:  Jul 13 2006
Impact:   Disclosure of system information, Disclosure of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  Exploit Included:  Yes  
Version(s): 1.9.5 and prior versions
Description:   A vulnerability was reported in SHOUTcast. A remote user can view files on the target system.

The software contains a logic error does not properly validate user-supplied input. The software attempts to validate the string before URL-decoding the string. As a result, a remote user can supply a specially crafted request containing URL-encoded directory traversal characters to view files on target system that are located outside of the content directory.

On some systems (such as Gentoo Linux), the server may be configured with root privileges.

A demonstration exploit request is provided:

GET /content/%2E./.%2E/%2E%2E/etc/passwd%00.mp3\n

The original advisory is available at:

http://people.ksp.sk/~goober/advisory/001-shoutcast.html

Goober reported this vulnerability.

Impact:   A remote user can view files on the target system.
Solution:   The vendor has issued a fixed version (1.9.7).
Vendor URL:  www.shoutcast.com/ (Links to External Site)
Cause:   Input validation error
Underlying OS:   Linux (Any), UNIX (FreeBSD), UNIX (OS X), UNIX (Solaris - SunOS), Windows (Any)

Message History:   None.


 Source Message Contents

Date:  Thu, 13 Jul 2006 15:04:34 -0400
Subject:  Arbitrary file read vulnerability in Shoutcast server <= 1.9.5.


http://people.ksp.sk/~goober/advisory/001-shoutcast.html
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC