Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   


Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker

Category:   Application (Security)  >   AbsoluteTelnet Vendors:   Celestial Software
AbsoluteTelnet SSH2 Client Software Access Control Bug May Disclose Passwords to Local Users Via Memory
SecurityTracker Alert ID:  1006013
SecurityTracker URL:
CVE Reference:   CVE-2003-0046   (Links to External Site)
Updated:  Jun 13 2008
Original Entry Date:  Jan 29 2003
Impact:   Disclosure of authentication information
Fix Available:  Yes  Vendor Confirmed:  Yes  Exploit Included:  Yes  
Version(s): 2.11 and prior versions
Description:   A vulnerability was reported in AbsoluteTelnet SSH2 client software from Celestial Software. A local user may be able to obtain the target user's password from memory. Other vendor implementations are also affected.

iDEFENSE reported that the client does not properly remove the user's password from memory after authentication. A local user with access to memory or to a memory dump can retrieve the target user's password.

According to the report, the password can be found in memory adjacent to the string "Password".

Impact:   A local user with access to system memory can obtain the client user's password.
Solution:   The vendor has developed a fixed version (2.12), which is currently in beta testing and available at:

When the beta period is completed, it will be available as a FREE update to all existing users at:

Vendor URL: (Links to External Site)
Cause:   Access control error
Underlying OS:   Windows (Any)

Message History:   None.

 Source Message Contents

Date:  Wed, 29 Jan 2003 12:51:42 -0500
Subject:  iDEFENSE Security Advisory 01.28.03: SSH2 Clients Insecurely Store Passwords

Hash: SHA1

iDEFENSE Security Advisory 01.28.03: SSH2 Clients Insecurely Store
Passwords (AbsoluteTelnet, SecureCRT, Entunnel, SecureFx, and PuTTY)
January 28, 2003


PuTTY is a free implementation of Telnet and SSH for Win32 platforms,
along with an xterm terminal emulator. More information is available at

SecureCRT provides security for remote access, file transfer, and data
tunneling by combining the open Secure Shell protocol with emulation.
Entunnel provides SSH2 data tunneling (port forwarding) services when
connected to an SSH2 server. The SecureFX client application is an SFTP
and FTP over an encrypted SSH2 client. More information is available at

AbsoluteTelnet is a terminal client program developed for the Microsoft
Windows platform. AbsoluteTelnet supports multiple protocols including
Telnet, SSH1, SSH2, TAPI Dialup and direct COM. More information is
available at


AbsoluteTelnet, SecureCRT, Entunnel, SecureFx, and PuTTY do not properly
scrub memory allowing an attacker with access to memory or a memory dump
to retrieve authentication information.

When connected via SSH2, an attacker can search memory or a memory dump
for logon credentials. Passwords transmitted by PuTTY can be found by
searching for the second occurrence of the string "password:". The user's
password is stored in plaintext shortly after this string. Passwords
transmitted by SecureCRT can be found by searching for the string
"ssh-connection". The logon and password is stored in plaintext on the
respective sides of this keyword. Passwords transmitted by AbsoluteTelnet
can be found by searching for the first occurrence of the string
"Password", that lies in a segment of read/write memory. The logon and
password is stored in plaintext on the respective sides of this keyword.


An attacker able to ascertain a target user's memory dump will be able to
recover passwords for remote systems. This is of special concern in shared


iDEFENSE has verified the existence of this vulnerability in the following
versions of the above mentioned clients:

• AbsoluteTelnet: latest (2.11)
• SecureCRT: latest (4.0.2) and 3.4.6
• SecureFX : 2.1.2 and 2.0.4
• Entunnel: 1.0.2 and earlier
• PuTTY: latest (0.53b)

Earlier versions of the tested clients as well as other clients may be
vulnerable as well.


Current development snapshots of PuTTY are believed to have this problem
fixed. Unfortunately, we are in the middle of heavy code restructuring and
not currently in a position to make a stable release, but the current
snapshots should be good enough for anyone for whom this is a problem.
- ---------------
The SSH password vulnerability discovered by iDEFENSE has been found to
exist in all versions of AbsoluteTelnet prior to (and including) version

Version 2.12, which Celestial Software will make available as a FREE
update to ALL existing users, fixes the problem by keeping password memory
"scrubbed" and free of plaintext copies of the password.

Version 2.12 is currently in beta testing pending the beta test group's
acceptance of the changes it contains.  Upon release, it will be available
for download at the Celestial Software website:

For a sneak peak at the 2.12 beta, go here:

Thanks to iDEFENSE for bringing this to my attention and for allowing
adequate time to make corrections! In particular, thanks to David Endler
for staying on top of this!
- ---------------
VanDyke Software recognizes the efforts of iDEFENSE in discovering this
security issue and commends iDEFENSE for the responsible manner in which
the security issue was made known so as to allow time for revisions to be
made before the information was released to the public.

The vulnerability reported by iDEFENSE exists in the following versions of
VanDyke Software client applications:

    SecureCRT: 4.0.2 and 3.4.7
    SecureFX : 2.1.2 and 2.0.4
    Entunnel: 1.0.2 and earlier

Earlier versions of these client applications are vulnerable as well.
VanDyke encourages all users whose licenses were purchased prior to June
1, 2000 to consider upgrading to the current version(s) of their licensed

Vulnerability fix downloads are available:
    SecureCRT 4.0.3 -
    SecureCRT 3.4.8 -

    SecureFX 2.1.3 -
    SecureFX 2.0.5 -

    Entunnel 1.0.3 -
- --------


The Mitre Corp.'s Common Vulnerabilities and Exposures (CVE) Project
assigned the following identification numbers to these issue:

CAN-2003-0046 - AbsoluteTelnet
CAN-2003-0047 - SecureCRT
CAN-2003-0048 - PuTTY, SecureFx, and Entunnel


12/13/2002      Issues disclosed to iDEFENSE
01/09/2003,, and 
01/09/2003      iDEFENSE clients notified
01/09/2003      Response received from Simon Tatham []
01/10/2003      Response received from Celestial Software 
01/10/2003      Response received from Van Dyke Software 
01/28/2003      Coordinated public disclosure


Knud Erik Højgaard ( discovered these vulnerabilities.

Get paid for security research

Subscribe to iDEFENSE Advisories:
send email to, subject line: "subscribe"


iDEFENSE is a global security intelligence company that proactively
monitors sources throughout the world — from technical
vulnerabilities and hacker profiling to the global spread of viruses
and other malicious code. Our security intelligence services provide 
decision-makers, frontline security professionals and network 
administrators with timely access to actionable intelligence
and decision support on cyber-related threats. For more information,
visit .

Version: PGP 8.0



Go to the Top of This SecurityTracker Archive Page

Home   |    View Topics   |    Search   |    Contact Us

Copyright 2015, LLC