SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   OS (Other)  >   Apple iOS Vendors:   Apple
Apple iOS Multiple Flaws Let Remote Users Execute Arbitrary Code and Deny Service and Let Remote and Local Users Obtain Potentially Sensitive Information
SecurityTracker Alert ID:  1035890
SecurityTracker URL:  http://securitytracker.com/id/1035890
CVE Reference:   CVE-2016-1790, CVE-2016-1801, CVE-2016-1802, CVE-2016-1803, CVE-2016-1807, CVE-2016-1808, CVE-2016-1811, CVE-2016-1813, CVE-2016-1814, CVE-2016-1817, CVE-2016-1818, CVE-2016-1819, CVE-2016-1823, CVE-2016-1824, CVE-2016-1827, CVE-2016-1828, CVE-2016-1829, CVE-2016-1830, CVE-2016-1831, CVE-2016-1832, CVE-2016-1833, CVE-2016-1834, CVE-2016-1835, CVE-2016-1836, CVE-2016-1837, CVE-2016-1838, CVE-2016-1839, CVE-2016-1840, CVE-2016-1841, CVE-2016-1842, CVE-2016-1847, CVE-2016-1852   (Links to External Site)
Date:  May 17 2016
Impact:   Denial of service via network, Disclosure of system information, Disclosure of user information, Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 9.3.2
Description:   Multiple vulnerabilities were reported in Apple iOS. A remote user can cause arbitrary code to be executed on the target user's system. A remote user can cause the target system to crash. A remote or local user can obtain potentially sensitive information. A remote user can gain elevated privileges.

An application can trigger a buffer overflow in the Accessibility function and determine kernel memory layout [CVE-2016-1790].

A remote user in a privileged network position can trigger a URL handling flaw in CFNetwork Proxies to obtain potentially sensitive user information [CVE-2016-1801].

An application can trigger a key processing flaw in CCCrypt to obtain potentially sensitive information [CVE-2016-1802].

An application can trigger a null pointer dereference in CoreCapture to execute arbitrary code with kernel-level privileges [CVE-2016-1803].

A local user can exploit a locking race condition in Disk Images to read kernel memory [CVE-2016-1807].

An application can trigger a memory corruption error in Disk Images to execute arbitrary code with kernel-level privileges [CVE-2016-1808].

A remote user can create a specially crafted image that, when loaded by the target user, will trigger a null pointer dereference in ImageIO and cause denial of service conditions [CVE-2016-1811].

An application can trigger a memory corruption error in IOAcceleratorFamily to execute arbitrary code with kernel-level privileges [CVE-2016-1817, CVE-2016-1818, CVE-2016-1819].

An application can trigger a null pointer dereference in IOAcceleratorFamily to cause denial of service condition [CVE-2016-1814].

An application can trigger a null pointer dereference in IOAcceleratorFamily to execute arbitrary code with kernel-level privileges [CVE-2016-1813].

An application can trigger a memory corruption error in IOHIDFamily to execute arbitrary code with kernel-level privileges [CVE-2016-1823, CVE-2016-1824].

An application can trigger a memory corruption error to execute arbitrary code with kernel-level privileges [CVE-2016-1827, CVE-2016-1828, CVE-2016-1829, CVE-2016-1830, CVE-2016-1831].

A local user can trigger a memory corruption error in libc to cause an application to terminate or execute arbitrary code [CVE-2016-1832].

A remote user can create specially crafted XML data that, when loaded by the target user, will trigger a memory corruption error in libxml2 and execute arbitrary code on the target user's system [CVE-2016-1833, CVE-2016-1834, CVE-2016-1835, CVE-2016-1836, CVE-2016-1837, CVE-2016-1838, CVE-2016-1839, CVE-2016-1840].

A remote user can create a specially crafted website that, when loaded by the target user, will trigger a memory corruption error in libxslt and execute arbitrary code on the target user's system [CVE-2016-1841].

A remote user in a privileged network position can trigger an error in the processing of shared links in MapKit to obtain potentially sensitive user information [CVE-2016-1842].

A remote user can create specially crafted web content that, when loaded by the target user, will trigger a memory corruption error in OpenGL and execute arbitrary code on the target user's system [CVE-2016-1847].

A physically local user can trigger a flaw in Siri in the processing of Twitter data to access contacts and photos from the lock screen [CVE-2016-1852].

Alex Chapman and Paul Stone of Context Information Security, Rapelly Akhil, Brandon Azad, CESG, Juwei Lin of TrendMicro, Marco Grassi (@marcograss) of KeenLab (@keen_lab), Tencent, Mateusz Jurczyk, Wei Lei and Liu Yang of Nanyang Technological University, Kostya Serebryany,
Klaus Rodewig, Ian Beer of Google Project Zero, daybreaker (via Trend Micro's Zero Day Initiative), Moony Li (@Flyic) and Jack Tang (@jacktang310) of Trend Micro, Lander Brandt (@landaire), Juwei Lin of TrendMicro, Karl Williamson, Sebastian Apelt,
Richard Shupak (https://www.linkedin.com/in/rshupak), Tongbo Luo and Bo Qu of Palo Alto Networks, and videosdebarraquito reported these vulnerabilities.

Impact:   A remote user can create content that, when loaded by the target user, will execute arbitrary code on the target user's system.

A remote user can cause the target system to crash.

A remote or local user can obtain potentially sensitive information on the target system.

A remote user can gain elevated privileges on the target system.

Solution:   The vendor has issued a fix (9.3.2).

The vendor's advisory is available at:

https://support.apple.com/en-us/HT206568

Vendor URL:  support.apple.com/en-us/HT206568 (Links to External Site)
Cause:   Access control error, Boundary error, Input validation error, State error

Message History:   This archive entry has one or more follow-up message(s) listed below.
May 17 2016 (Apple Issues Fix for Apple TV) Apple iOS Multiple Flaws Let Remote Users Execute Arbitrary Code and Deny Service and Let Remote and Local Users Obtain Potentially Sensitive Information
Apple has issued a fix for Apple TV.
May 17 2016 (Apple Issues Fix for Apple Watch) Apple iOS Multiple Flaws Let Remote Users Execute Arbitrary Code and Deny Service and Let Remote and Local Users Obtain Potentially Sensitive Information
Apple has issued a fix for Apple Watch.
May 17 2016 (Apple Issues Fix for Apple OS X) Apple iOS Multiple Flaws Let Remote Users Execute Arbitrary Code and Deny Service and Let Remote and Local Users Obtain Potentially Sensitive Information
Apple has issued a fix for Apple OS X.
May 17 2016 (Apple Issues Fix for Apple OS X) Apple iOS Multiple Flaws Let Remote Users Execute Arbitrary Code and Deny Service and Let Remote and Local Users Obtain Potentially Sensitive Information
Apple has issued a fix for Apple OS X.
Jul 19 2016 (Apple Issues Fix for Apple Watch) Apple iOS Multiple Flaws Let Remote Users Execute Arbitrary Code and Deny Service and Let Remote and Local Users Obtain Potentially Sensitive Information
Apple has issued a fix for Apple Watch.
Jul 19 2016 (Apple Issues Fix for Apple iTunes) Apple iOS Multiple Flaws Let Remote Users Execute Arbitrary Code and Deny Service and Let Remote and Local Users Obtain Potentially Sensitive Information
Apple has issued a fix for Apple iTunes for Windows.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2017, SecurityGlobal.net LLC