SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Commerce)  >   Apache OFBiz Vendors:   Apache Software Foundation
Apache OFBiz Java Deserialization Flaw Lets Remote Users Obtain Potentially Sensitive Information on the Target System
SecurityTracker Alert ID:  1035513
SecurityTracker URL:  http://securitytracker.com/id/1035513
CVE Reference:   CVE-2016-2170   (Links to External Site)
Date:  Apr 11 2016
Impact:   Disclosure of system information, Disclosure of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 13.07.0 - 13.07.02; 12.04.0 - 12.04.05
Description:   A vulnerability was reported in Apache OFBiz. A remote user can obtain potentially sensitive information on the target system.

A remote user can send a specially crafted request to trigger a Java deserialization flaw and view potentially sensitive information on the target system.

Impact:   A remote user can obtain potentially sensitive information on the target system.
Solution:   The vendor has issued a fix (12.04.06, 13.07.03).

The vendor's advisory is available at:

https://blogs.apache.org/ofbiz/date/20160405

Vendor URL:  blogs.apache.org/ofbiz/date/20160405 (Links to External Site)
Cause:   Access control error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Date:  Fri, 8 Apr 2016 22:41:37 +0200
Subject:  [oss-security] CVE-2016-2170: Apache OFBiz information disclosure vulnerability

==========================================
CVE-2016-2170: Apache OFBiz information disclosure vulnerability

Severity: Important

Vendor:
The Apache Software Foundation

Versions Affected:
Apache OFBiz 13.07.02 and 13.07.01
Apache OFBiz 12.04.05 and earlier releases in the series (12.04.*)
The unsupported releases 11.04.*,  10.04.*  and 09.04 versions are also affected but not fixed.

Description:
The infamous Java serialization vulnerability

Mitigation:
13.07.* users should upgrade to 13.07.03
12.04.05 users should upgrade to 12.04.06 (Note though that in 12.04.06 RMI is not deactivated so you should use the recommended remediation: notsoserial)

Credit:
This infamous issue was confirmed to be an issue in OFBiz by the OFBiz team, due to two external Java libraries and RMI usage.

Remediation:
Apart when using RMI with 12.04.03 version nothing is needed. But with any version, if you use  JNDI, JMX or Spring and maybe other Java classes, 
please check the references (hint: use notsoserial with your own whitelist)

References:
https://cwiki.apache.org/confluence/display/OFBIZ/The+infamous+Java+serialize+vulnerability

==========================================
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2017, SecurityGlobal.net LLC