SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   Apache OpenOffice Vendors:   Apache Software Foundation, OpenOffice.org
Apache OpenOffice Bugs Let Remote Users Obtain Files and Execute Arbitrary Code
SecurityTracker Alert ID:  1034091
SecurityTracker URL:  http://securitytracker.com/id/1034091
CVE Reference:   CVE-2015-4551, CVE-2015-5212, CVE-2015-5213, CVE-2015-5214   (Links to External Site)
Date:  Nov 6 2015
Impact:   Disclosure of system information, Disclosure of user information, Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 4.1.1 and prior
Description:   Several vulnerabilities were reported in Apache OpenOffice. A remote user can cause arbitrary code to be executed on the target user's system. A remote user can obtain files on the target system.

A remote user can create a specially crafted document that, when loaded by the target user, will trigger a bug in the handling of files and templates and access arbitrary documents on the target user's system [CVE-2015-4551].

Federico "fox" Scrinzi reported this vulnerability.

A remote user can create an ODF file containing specially crafted PrinterSetup data that, when loaded by the target user, will execute arbitrary code on the target user's system [CVE-2015-5212].

A remote user can create a specially crafted DOC file that, when loaded by the target user, will trigger an integer overflow and execute arbitrary code on the target user's system [CVE-2015-5213].

A remote user can create a DOC file with specially crafted bookmarks that, when loaded by the target user, will trigger an array index error and execute arbitrary code on the target user's system [CVE-2015-5214].

Impact:   A remote user can create content that, when loaded by the target user, will execute arbitrary code or obtain files on the target user's system.
Solution:   The vendor has issued a fix (4.1.2).

The vendor's advisories are available at:

http://www.openoffice.org/security/cves/CVE-2015-4551.html
http://www.openoffice.org/security/cves/CVE-2015-5212.html
http://www.openoffice.org/security/cves/CVE-2015-5213.html
http://www.openoffice.org/security/cves/CVE-2015-5214.html

Vendor URL:  www.openoffice.org/security/cves/CVE-2015-4551.html (Links to External Site)
Cause:   Access control error, Boundary error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2016, SecurityGlobal.net LLC