SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (VPN)  >   OpenSSH Vendors:   OpenSSH.org
OpenSSH AcceptEnv Wildcard Processing Flaw May Let Remote Authenticated Users Bypass Environment Restrictions
SecurityTracker Alert ID:  1029925
SecurityTracker URL:  http://securitytracker.com/id/1029925
CVE Reference:   CVE-2014-2532   (Links to External Site)
Date:  Mar 18 2014
Impact:   Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 6.6
Description:   A vulnerability was reported in OpenSSH. A remote authenticated user can bypass environment restrictions in certain cases.

When configured for environment passing (not the default), the software does not properly process wildcard characters on AcceptEnv lines in the 'sshd_config' configuration file. A remote user may be able to supply specially crafted parameter values to bypass environment restrictions and set certain environment variables.

Impact:   A remote authenticated user can bypass environment restrictions in certain cases and set certain environment variables.
Solution:   The vendor has issued a fix (6.6).

The vendor's advisory is available at:

http://www.openssh.org/txt/release-6.6

Vendor URL:  www.openssh.org/txt/release-6.6 (Links to External Site)
Cause:   Access control error, Input validation error
Underlying OS:   Linux (Any), UNIX (Any), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Jun 18 2014 (IBM Issues Fix for IBM AIX) OpenSSH AcceptEnv Wildcard Processing Flaw May Let Remote Authenticated Users Bypass Environment Restrictions
IBM has issued a fix for IBM AIX 5.3, 6.1, and 7.1.



 Source Message Contents

Date:  Tue, 18 Mar 2014 04:47:02 +0000
Subject:  http://www.openssh.org/txt/release-6.6


http://www.openssh.org/txt/release-6.6

CVE-2014-2532
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC