SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (VPN)  >   OpenSSL Vendors:   OpenSSL.org
OpenSSL Incorrect Version Number Used in ssl_get_algorithm2() Lets Remote Users Deny Service
SecurityTracker Alert ID:  1029548
SecurityTracker URL:  http://securitytracker.com/id/1029548
CVE Reference:   CVE-2013-6449   (Links to External Site)
Updated:  Jan 7 2014
Original Entry Date:  Jan 1 2014
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  Exploit Included:  Yes  
Version(s): 1.0.1x prior to 1.0.1f
Description:   A vulnerability was reported in OpenSSL. A remote user can cause denial of service conditions.

The ssl_get_algorithm2() function in 'ssl/s3_lib.c' uses an incorrect version number. A remote user can send specially crafted data (using TLS 1.2) to cause the target service to crash.

Ron Barber reported this vulnerability.

Impact:   A remote user can cause the target service to crash.
Solution:   The vendor has issued a fix (1.0.1f).

The source code fix is also available at:

http://git.openssl.org/gitweb/?p=openssl.git;a=commit;h=ca989269a2876bae79393bd54c3e72d49975fc75

Versions 1.0.2 and later are not affected.

Vendor URL:  www.openssl.org/ (Links to External Site)
Cause:   State error
Underlying OS:   Linux (Any), UNIX (Any), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Jan 8 2014 (Red Hat Issues Fix) OpenSSL Incorrect Version Number Used in ssl_get_algorithm2() Lets Remote Users Deny Service   (bugzilla@redhat.com)
Red Hat has issued a fix for Red Hat Enterprise Linux 6.
Jan 15 2014 (FreeBSD Issues Fix) OpenSSL DTLS Retransmission Error May Let Remote Users Deny Service   (FreeBSD Security Advisories <security-advisories@freebsd.org>)
FreeBSD has issued a fix for 10.0-PRERELEASE.
Feb 26 2014 (IBM Issues Fix for IBM AIX) OpenSSL Incorrect Version Number Used in ssl_get_algorithm2() Lets Remote Users Deny Service
IBM has issued a fix for IBM AIX 5.3, 6.1, and 7.1.
Apr 14 2014 (F5 Issues Advisory for F5 BIG-IP) OpenSSL Incorrect Version Number Used in ssl_get_algorithm2() Lets Remote Users Deny Service
F5 has issued an advisory for F5 BIG-IP.



 Source Message Contents

Date:  Wed, 01 Jan 2014 20:50:12 +0000
Subject:  OpenSSL


http://git.openssl.org/gitweb/?p=openssl.git;a=commit;h=ca989269a2876bae79393bd54c3e72d49975fc75

CVE-2013-6449
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC