SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Database)  >   MySQL Vendors:   MySQL.com, Oracle
MySQL Multiple Bugs Let Remote Authenticated Users Execute Arbitrary Code, Deny Service, and Partially Access and Modify Data
SecurityTracker Alert ID:  1029184
SecurityTracker URL:  http://securitytracker.com/id/1029184
CVE Reference:   CVE-2012-2750, CVE-2013-2251, CVE-2013-3839, CVE-2013-5767, CVE-2013-5770, CVE-2013-5786, CVE-2013-5793, CVE-2013-5807   (Links to External Site)
Date:  Oct 15 2013
Impact:   Denial of service via network, Disclosure of system information, Disclosure of user information, Execution of arbitrary code via network, Modification of system information, Modification of user information, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 5.1.70, 5.5.32, 5.6.12; and prior versions
Description:   Multiple vulnerabilities were reported in MySQL. A remote authenticated user can execute arbitrary code on the target system. A remote authenticated user can cause denial of service conditions. A remote authenticated user can access and modify data.

A remote authenticated user can exploit a flaw in the Service Manager component to gain full control of the target system [CVE-2013-2251]. [Editor's note: This underlying vulnerability resides in the third party Apache Struts component.]

A remote authenticated user can exploit a flaw in the Replication component to partially access and modify data [CVE-2013-5807].

A remote authenticated user can partially deny service. The InnoDB [CVE-2013-5786, CVE-2013-5793], Optimizer [CVE-2012-2750, CVE-2013-3839, CVE-2013-5767], and Locking [CVE-2013-5770] components are affected.

The following researchers reported these and other Oracle vulnerabilities:

Adam Gowdiak of Security Explorations; Adam Willard of Foreground Security; Adi Ludmer of McAfee Labs; Ajinkya Patil of AVsecurity.in; Alex Kouzemtchenko of Security Research Lab via CERT/CC; Alex Rajan of Network Intelligence; Alexander P olyakov of ERPScan; Alexander Tlyapov of Positive Technologies; Alexey Osipov of Positive Technologies; Alexey Tyurin of ERPScan (Digital Security Research Group); Anagha Devale-Vartak of AVsecurity.in; Andrea Micalizzi aka rgod, working with HP's Zero Day Initiative; Andrew Davies formerly of NCC Group; Ben Murphy via HP's Zero Day Initiative; CERT/CC; Chris Ries via the Exodus Intelligence Program; Dave Bryant of Orion Health; Dmitry Sklyarov of Positive Technologies; Esteban Martinez Fayo formerly of Application Security Inc.; HUAWEI PSIRT; James Forshaw of Context Information Security; Jeroen Frijters; Jon Passki of Security Research Lab via CERT/CC; Juraj Somorovsky of Ruhr-University Bochum; Manuel Garcia Cardenas of Internet Security Auditors; Positive Research Center (Positive Technologies Company); Qinglin Jiang formerly of Application Security Inc; Rohan Stelling of BAE Systems Detica; Sam Thomas of Pentest Limited; Timur Yunusov of Positive Technologies; Tom Parker of Orion Health; Travis Emmert via iDefense; Vinesh N. Redkar; Will Dormann of CERT/CC; and Yuki Chen of Trend Micro.

Impact:   A remote authenticated user can execute arbitrary code on the target system.

A remote authenticated user can cause partial denial of service conditions on the target system.

A remote authenticated user can access and modify data.

Solution:   The vendor has issued a fix as part of Oracle Critical Patch Update Advisory - October 2013.

The vendor's advisory is available at:

http://www.oracle.com/technetwork/topics/security/cpuoct2013-1899837.html

Vendor URL:  www.oracle.com/technetwork/topics/security/cpuoct2013-1899837.html (Links to External Site)
Cause:   Not specified
Underlying OS:   Linux (Any), UNIX (Any), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Feb 18 2014 (Red Hat Issues Fix) MySQL Multiple Bugs Let Remote Authenticated Users Execute Arbitrary Code, Deny Service, and Partially Access and Modify Data   (bugzilla@redhat.com)
Red Hat has issued a fix for Red Hat Enterprise Linux 5.



 Source Message Contents

Date:  Tue, 15 Oct 2013 22:43:17 +0000
Subject:  MySQL


CVE-2012-2750
CVE-2013-2251
CVE-2013-3839 
CVE-2013-5767
CVE-2013-5770
CVE-2013-5786
CVE-2013-5793
CVE-2013-5807
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC