SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   BlackBerry Enterprise Server Vendors:   Research In Motion Limited
BlackBerry Enterprise Server Buffer Overflow in Attachment Service Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1024577
SecurityTracker URL:  http://securitytracker.com/id/1024577
CVE Reference:   CVE-2010-2601   (Links to External Site)
Date:  Oct 14 2010
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 4.1.7, 5.0.0, 5.0.1, 5.0.2; and prior versions
Description:   A vulnerability was reported in BlackBerry Enterprise Server. A remote user can execute arbitrary code on the target system.

A remote user can send a specially crafted PDF file to trigger a buffer overflow in the Attachment Service PDF distiller and execute arbitrary code on the target BlackBerry Enterprise Server when the target user opens the attachment on a BlackBerry device. The code will run on the BlackBerry Enterprise Server with the privileges of the target service.

Impact:   A remote user can execute arbitrary code on the target system.
Solution:   The vendor has issued a fix.

For BlackBerry Enterprise Server Express version 5.0.2 for Microsoft Exchange:

Interim Security Update 1 for BlackBerry Enterprise Server Express version 5.0.2.

For BlackBerry Enterprise Server version 5.0.0 for Microsoft Exchange and IBM Lotus Domino:

Interim Security Update 4 for BlackBerry Enterprise Server software version 5.0.0.

For BlackBerry Enterprise Server version 5.0.1 for Microsoft Exchange, IBM Lotus Domino, and Novell GroupWise:

Interim Security Update 1 for BlackBerry Enterprise Server software version 5.0.1.

For BlackBerry Enterprise Server version 5.0.2 for Microsoft Exchange and IBM Lotus Domino:

Interim Security Update 1 for BlackBerry Enterprise Server software version 5.0.2.

For BlackBerry Enterprise Server version 4.1.7 for Microsoft Exchange and IBM Lotus Domino:

Interim Security Update 2 for BlackBerry Enterprise Server software version 4.1.7.

For BlackBerry Enterprise Server version 4.1.7 for Novell GroupWise:

Interim Security Update 1 for BlackBerry Enterprise Server software version 4.1.7.

For BlackBerry Enterprise Server version 4.1.6 for Microsoft Exchange, IBM Lotus Domino, and Novell GroupWise:

Interim Security Update 5 for BlackBerry Enterprise Server software version 4.1.6.

The vendor's advisory is available at:

http://www.blackberry.com/btsc/search.do?cmd=displayKC&externalId=KB24547

Vendor URL:  www.blackberry.com/btsc/search.do?cmd=displayKC&externalId=KB24547 (Links to External Site)
Cause:   Boundary error
Underlying OS:   Windows (2000), Windows (2003), Windows (2008)

Message History:   None.


 Source Message Contents

Date:  Thu, 14 Oct 2010 14:38:14 +0000
Subject:  BlackBerry Enterprise Server


http://www.blackberry.com/btsc/search.do?cmd=displayKC&externalId=KB24547

CVE-2010-2601
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC